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TPCloud and TPTransfer Guide
by Touch Panel Control

The following is a guide to:

● installation and licensing of TPControl for Apple (iOS) devices

● installation and operation of TPTransfer for Microsoft Windows

● online management and deployment using TPCloud (tpcloud  .  touchpanelcontrol  .  com)

TPControl has been developed for use with the following:

● Android devices

● Apple iPhone, iPad / iPad mini, and iPod Touch devices

● Windows 8 / Windows RT devices

Overview

Touch Panel Control provides three key components for the support and integration of TPControl:

1. TPControl

TPControl is an application developed to run on Apple, Android and Windows 8 /

Windows RT devices, replicating functionality of AMX Modero G4+ touch panels.

2. TPCloud (tpcloud  .  touchpanelcontrol  .  com)

Our online service for registration and management for remote deployment

of TPControl resources.

Services include;

● BYOD Token management for AMX NetLinx Masters 

● Token management, including registration and deauthorization for TPControl devices

● Management of Settings and TP4 file options for TPControl device deployment

● Push Messaging for licensed TPControl devices

● AMX TPDesign4 file repository

● and much more...

3. TPTransfer (for Microsoft Windows)

The application used to transfer AMX TPDesign4 files directly to TPControl

devices.

TPTransfer can also be used to generate TPControl BYOD files for use with BYOD licensed AMX 

NetLinx Masters.
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Do you have a TPC User ID/Email account?

● If you already have an account with Touch Panel Control (http://www.touchpanelcontrol.com) 

or TPCloud (http://tpcloud.touchpanelcontrol.com), you already have a TPC User ID that can 

be used to log in to either website.

● If you do not have an account, go to TPCloud (http://tpcloud.touchpanelcontrol.com) and 

Register – it's free to do.

The email you use to register becomes your TPC User ID

Prerequisites

● Apple iPod Touch, iPhone or iPad / iPad mini, capable of running iOS4.3+

(iOS5+ required for TPControl BYOD support)

Download TPControl using the App Store application on the device

Click here for the TPControl for   Apple application link.

● A WiFi connection on your TPControl device for connection to an AMX NetLinx master

● For setup via TPCloud, a computer running a suitable web browser is required

● For setup via TPTransfer (developed for Microsoft Windows XP/Vista/7), a suitable computer is 

required.

TPTransfer is available from the Downloads section of the Touch Panel Control website.

● AMX TPDesign4 available from www  .  amx  .  com used to create and edit custom TP4 files for use 
with TPControl.
For more information, please refer to the section titled TPDesign4 - Creating a panel design

● To license a device, either a Trial license Token or Full license Token is required.

Trial and Full license Tokens can be obtained from our Products page at 

www.touchpanelcontrol.com/products.html, with Full license Tokens also available via the AMX 

Dealer/Distribution channel

● An Internet connection is required at the time of license validation, during device registration

NOTE:

Connection to AMX NetLinx control systems from TPControl devices, requires either that;

a) the TPControl device is licensed with a TPControl Trial or Full license Token

or

b) the AMX NetLinx Master be licensed with a BYOD License Token.

If neither of the two licensing conditions above are satisfied, TPControl will remain in “Offline Mode”.
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TPControl

TPControl is an application for your Apple, Android and Windows 8 / Windows RT devices, enabling 

them to talk directly to an AMX NetLinx Master just like a native AMX touch panel.

Upon initial installation of TPControl on your device, a default demonstration UI file is presented. The 

demo file highlights a small portion of AMX G4 functionality, and may also include TPControl specific 

features, such as VoiceControl and Push Messaging.

Customisation of UI designs is facilitated using AMX's TPDesign4 touch panel interface design 

software, resulting in files that can be loaded into TPControl via TPTransfer, TPCloud, or BYOD 

Licensed NetLinx masters. TPControl devices interact and operate seamlessly with the AMX NetLinx 

Master, just like other native AMX system components.

TPControl Installation

Download the TPControl application by searching for "TPControl" within the App Store application 

on your device.

Congratulations! You will now have a shiny new TPControl icon on your HOME screen, that looks a 

little like this!

TPControl Device Settings

For a comprehensive list of configuration options and device specific settings within TPControl, please

refer to the 'TPControl for Apple - Device Settings' document, available via our Downloads 

(www.touchpanelcontrol.com/catalog/product/download) page.

Documentation is also available within 'TPTransfer -> Documentation'.

Refer to the section How to access TPControl Device Settings for information on accessing 
administrative settings for TPControl.

TPControl API Command List

As well as extensive support for AMX G3/G4 API commands, TPControl also supports API commands 

and features that may not be supported by AMX touch panels. 

Please refer to the "TPControl - API Commands supported in addition to AMX commands" 

document, available via our Downloads (www.touchpanelcontrol.com/catalog/product/download) 

page.

Documentation is also available within 'TPTransfer  Documentation'.→
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TPDesign4 - Creating a panel design

AMX provide a software application called TPDesign4 which is used to create custom user interface 

designs for AMX Modero touch panels.

Importantly, TPControl is TP4 file agnostic, meaning that TP4 files created for use with AMX panels 

can also be transferred to TPControl without any conversion needed. Screen Resize options available 

in TPControl provide scaling options to suit upsizing/downsizing requirements.

Using TPDesign4, you can;

• create new panel designs from the included TPControl (TPC) panel type templates

• choose to convert an existing AMX TP4 file using "TPDesign4 -> File -> Save As Different Panel

Type..."

Contact AMX at www.amx.com for more information regarding TPDesign4.
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Token registration and transferring TP4 files
Touch Panel Control provide two methods for registration of TPControl device Tokens:

1. Token registration On-Device

2. Token registration via TPCloud

NOTE: In order to successfully complete TPControl device registration, the device must have 

unrestricted access to the Internet

Methods for transferring TP4 files to TPControl devices include:

1. TPCloud

Refer to Step 8 on page 10 for more details

2. TPTransfer

Refer to page 12 for more details

3. BYOD Licensed NetLinx masters

Refer to our TPControl – BYOD How To guide for details
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Token registration On-Device
On your device, within Settings for TPControl, a 'Token Registration' option is provided.

1. Enable the Token Registration option, and return to TPControl.

A window similar to that shown below, will be presented:

2. Enter your 'TPC User ID (email)' and the Token value in each respective field.

3. Press 'SUBMIT' to initiate the registration process.

All going well, within a few seconds, a window will appear stating the TPControl device 

registration was successful!

Congratulations – your TPControl device is licensed, permitting connection to any AMX NetLinx 
Master.
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Token registration via TPCloud
TPCloud (tpcloud  .  touchpanelcontrol  .  com) is our online, web-browser based service for management, 

registration and remote deployment of TPControl resources.

TPControl devices can retrieve information stored on TPCloud, including configuration Settings and 

TP4 files, all from a single button press on the device, or via the 'TPCloud update' option within 

Settings for TPControl on the device.

TPCloud provides a method for restoring and updating TPControl configurations, providing remote 

deployment functionality, triggered with as little as a single button press on the TPControl device.

TPCloud features include:

● Token management

● BYOD Token management for AMX NetLinx Masters

Refer to our TPControl – BYOD How To guide for details

● Token management for TPControl devices

● Add AMX distributed Tokens to your account

● Registration of TPControl devices via PIN number: Tokens > Token: View Details

● Deauthorization of TPControl devices: Tokens > Token: Deauthorize

● Create/Edit/Delete custom labels for organising Tokens into; Projects, Customers, 

Locations

● TP4 File management

● Generate and download TP4 files for use with BYOD Licensed NetLinx Masters

● Upload TP4 files to your TPCloud file repository, complete with multi-file upload support

● Assign a TP4 file from your online repository to one or many Tokens for TPControl devices

● Device management

● Configure Settings for each TPControl device Token and assign TP4 files, providing a 

complete device profile that can be retrieved by the TPControl device at any time

● Deploy customisable Push Messages for updates and administration, directly to registered 

TPControl devices.

● Multi-user

● Invite users to your TPCloud Company, to view and manage shared Tokens

TPCloud provides many useful features for the deployment and maintenance of TPControl devices. Of 

note, Push Messaging is available via Tokens > Token: Push Messages providing the ability to deploy 

customisable messages directly to registered TPControl devices.

A NetLinx module, available from the Downloads section of our website, can be used to deploy Push 

Messages to TPControl devices directly from your control system.
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Token registration using TPCloud PIN

To complete TPControl device registration using TPCloud PIN, please follow these steps:

1. Login to tpcloud  .  touchpanelcontrol  .  com using your TPC User ID (email) and credentials.

2. Select the Tokens tab option.

3. Option A: AMX distributed Tokens

Tokens prefixed with 'TPC-1-' are AMX distributed Tokens.

Use the 'Add Token' option to add the Token to your TPCloud account.

Option B: Touch Panel Control distributed Tokens

Tokens prefixed with 'TPC-0-' are Touch Panel Control distributed Tokens.

These Tokens are already be associated with your TPCloud account.

4. Locate the Token by selecting the 'All Tokens' filter, and select the Token device icon.

NOTE: Checkbox selection is available, providing a subset of actions that can be performed 

across one or many Tokens.

For the purpose of this guide, select the Token line item rather than the checkbox.

5. Select the 'View Details' tab, if not already selected, as shown below.

Example view of TPCloud: Token management: View Details

6. Select the 'Create a PIN' option.

A 5-digit PIN number will be generated for the Token, and the PIN will expire within 30-Days if 

unused. If the PIN does expire prior to registration, simply use the 'Create a PIN' option again.

A quick reference to the current PIN will be indicated on the Token summary line.

NOTE: The 'Create a PIN' option is available for valid unregistered Tokens.
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7. Select the 'Settings and TP4 files' tab.

All TPControl device Settings and TP4 files can be configured here. Name relevant connection 

Profiles, and assign Host and Device ID parameters as a minimum requirement.

NOTE: the 'TPCloud update options' for 'TP4 Files' and 'Settings', determine which associated 

resources the device retrieves when it processing a 'TPCloud update'.

Example view of TPCloud: Token management: Settings and TP4 files
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8. Options to change TP4 file(s) assigned to the Token are provided, along with options to upload 

TP4 files to TPCloud. Files are retained within your online TP4 file repository, and can be 

reviewed and organised by selecting the main 'Files' tab at the top of TPCloud.

Assign a different TP4 file to each available TP4 File Slot. To associate a particular File Slot with

a Connection Profile, first choose the profile then assign your chosen slot using the 'TP4 File 

Slot' drop-down list available within the 'Profile Settings' section.

NOTE: Each Token has a minimum of 2 x TP4 File Slots (on supported platforms), with the 

ability to add more slots, by purchasing TP4 File Slot KEYs. The KEYs can then be applied to 

Full license Tokens using the 'Add another TP4 File Slot' option.

9. On the device with TPControl installed, go to Settings -> TPControl.

Scroll down the list of items and select the 'TPCloud PIN' option.

Return to/Launch TPControl...

10. A 'TPCloud PIN' window will be presented.

11. If not already shown, select the PIN field to present a keyboard, then enter the PIN generated 

in Step 6 above. PINs are not case-sensitive.

12. Select the 'Send' option within the 'TPCloud PIN' dialog window.

Provided the device has Internet access, the PIN entered will be validated with the Touch Panel

Control registration servers, and the device will be assigned to the Token.

Successful registration will result in the device updating any Settings and/or TP4 files for the 

respective Token, as configured within TPCloud.

Any errors will be reported within the 'TPCloud PIN' dialog window.

Congratulations – your TPControl device is licensed, permitting connection to any AMX NetLinx 
Master.

Please explore tpcloud  .  touchpanelcontrol  .  com for further TPCloud features.
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Sharing Tokens in TPCloud

Tokens can be shared with users invited to your TPCloud account, using an option called 'Make Token

Public'. More on this later...

So, every TPCloud user can invite other users to view and manage their Tokens. Inviting users 

provides access only to Tokens that have been made 'Public' by the TPCloud account that the invite 

originates from. Here is a scenario where inviting users is advantageous:

● An end-user of TPControl, may request that TPControl Tokens be registered to their own 

personal TPCloud account. As such, the end-user from their TPCloud account, can invite the 

TPControl/AMX integrator to administer their TPCloud account. This permits the integrator to 

provide updates and support for the end-users TPControl devices via TPCloud.

The integrator, having accepted the invite, can simply log into their own personal TPCloud 

account, using their own credentials, and see any Tokens being shared with them.

The end-user can assign and revoke access to one or more integrators as and when required.

To invite other users to your TPCloud account...

● Login to (or create) the TPCloud account that will be inviting other users.

● Select the TPC User ID/Email in the top-right corner of TPCloud, and choose the 'My Company' 

option.

● In the 'Invite new people: Email' field, enter the email for the person to be invited, select their 

'Role (Admin/User/Guest)' and complete by pressing the 'Invite' option. An email will be 

issued, inviting them to access TPCloud.

When the invited TPCloud user logs into their own TPCloud account, if they have access to more than

one TPCloud company, a drop-down list of TPCloud Companies is available for selection. This list is 

indicated by an arrow beside the current TPCloud Company Name presented in the top-left corner of 

TPCloud (directly under the 'TPCloud' logo). By selecting the relevant TPCloud Company, users can 

review their own Tokens, or those being shared from another Company.

NOTE: Only Tokens that are made Public (by the owner of the Token) will be accessible when 

reviewing a TPCloud Company you have been invited to.

To make one of your own Tokens Public, go to 'TPCloud -> Tokens -> (token) -> View Details' and 

select the 'Make Token Public' option.

Furthermore, Tokens cannot be shared on a per-user basis, so when a Token is made Public, it will be

shared with all users that are invited to the Company's account.

Filtering Tokens

Various filters are provided to help quickly review specific Tokens. e.g. e 'All Tokens', 'Tokens 

Shared with Me', 'My Shared Tokens'. Custom filters can be created using the 'Create new label' 

option.
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Transferring files using TPTransfer
IMPORTANT: Registration of TPControl devices via TPTransfer has been deprecated, and is no 
longer supported. Instead, use O  n-  D  evice   Token Registration or TPCloud to register devices.

TPTransfer is our Microsoft Windows based application for locally transferring TP4 files to TPControl 

devices.

TPTransfer can also be used to generate TPControl BYOD files for use with BYOD licensed AMX 

NetLinx Masters.

TPTransfer can be downloaded from the Downloads section of our website: 

www  .  touchpanelcontrol  .  com

TPTransfer provides the following features:

● Token Deauthorization

Access to the Internet must be available from the computer running TPTransfer, for active 

TPControl device Deauthorization i.e. the TPControl device must be available also.

Deauthorization is the process of releasing a Token registration, permitting re-use of the Token 

on a new/replacement device.

● TP4 file transfer

TPTransfer can be used to transfer TP4 files directly to TPControl devices. Internet access is not 

required to when using TPTransfer to transfer files to TPControl devices.

TPTransfer Installation

1. Download TPTransfer from the Downloads section at www  .  touchpanelcontrol  .  com

2. If AMX TPDesign4 is running, please close it.

3. Run the TPTransfer executable downloaded in Step 1 to begin installation.

The installer executes a patch process which installs TPC template files for use in TPDesign4 

(refer to the screenshot below).

NOTE: If TPDesign4 was running during the installation, please close TPDesign4 and restart in 

order to see and use the TPC template options.

Continued next page...
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The TPC templates enable you to create new panel designs or convert existing designs, to 

resolutions typically available agnosticon TPControl devices.

Importantly, TPControl is TP4 file agnostic, meaning that TP4 files created for use with AMX 

panels can also be transferred to TPControl without any conversion needed. Screen Resize 

options available in TPControl provide scaling options to suit upsizing/downsizing requirements.

However, it is recommended that you convert to TPC templates, to benefit from all available 

features within TPControl.
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TPTransfer - Configuration

NOTE: TPTransfer will only connect to your device if TPControl is running with full screen focus on 
your TPConrtol device.

Configure Network adapters and locate TPControl devices

1. With TPTransfer running, select the "Tools" button, followed by "Settings" from the drop-down 

list.

2. Ensure that the required network adapter on your computer is selected, by choosing;

"Tools -> Settings -> Network".

Selected adapters are indicated with a green TICK symbol beside the listed adapter.

Multiple adapters can be selected at the same time.

Confirm that the Network adapter you intend to use has a valid IP address that falls within the 

same subnet as your TPControl enabled device.

NOTE: For simplicity, your TPControl device must be configured to be connected to the same 

LAN and IP subnet as the TPTransfer computer.

3. On your TPControl device, if you have not already, ensure that you have configured the devices 

Wi-Fi connection to be connected to the same LAN and IP subnet as the TPTransfer computer.

4. Start the TPControl application and wait for it to finish loading.

The first load may take a moment or two as it prepares the default demonstration file.

5. Within TPTransfer, if the "Automatic Device Polling" option is enabled on the Network settings 

(refer image above), then each discovered TPControl device will be listed automatically.

Alternately, click the "Find Devices" button in TPTransfer to discover TPControl devices on your 

network.

You can also manually add a device by choosing the "Add Device" option, then specifying the 

Host/IP address and Port (default 10700).

Your TPControl device will be listed in TPTransfer.
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Transferring TP4 files to TPControl

1. If the file you want to transfer is currently open in TPDesign4, close it, and return to TPTransfer.

2. In TPTransfer, for the target device you wish to transfer to, choose the relevant Slot ID (if 

applicable) from those available for the device, and then click the  option, followed by 

locating and choosing the TP4 file.

Alternately, you may drag-n-drop the TP4 file directly onto the target device in TPTransfer, or 

drag-n-drop between the Filenames for listed devices. Then select the  option.

For TPControl devices that support more than one TP4 File Slot, a slot identifier drop-down list 

will be available.

3. TPTransfer will attempt to connect to your TPControl device and commence transfer of the TP4 

file. Progress is shown both in TPTransfer and on the device.

4. When the transfer is completed, if the target file-slot matches the current file-slot active on the 

device, then TPControl will automatically display the new file design.

The first load of the design will take a few moments to complete, while TPControl pre-processes 

the design files. Subsequent display of the same file, TPControl will load much more quickly.

5. Configure your AMX NetLinx master connection parameters within the TPControl device 

"Settings" as required.

Refer to the previous section titled 'TPControl Device Settings' for more information.
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Deauthorizing Tokens

Deauthorization is the process used to de-register a registered Token. This frees the Token, and de-

registers TPControl from use on the original device. This allows the Token to then be registered with 

another device.

So, if the original device is lost, stolen, replaced or upgraded, you can easily migrate the Token for 

use on a new device.

Deauthorization using TPCloud

Two options for deauthorizing Tokens are provided from TPCloud, and are located within the 

Deauthorize tab for each Token.

Each is explained below:

Deauthorize and re-assign by PIN

This is perhaps the simplest way to Deauthorize a device when upgrading to a new device, assuming 

the original device is still available with TPControl installed on it.

The user enters a 5 digit PIN into the current registered device, then again on the New device.

Deauthorize by Request

No longer have your original device? Use this option to send a request through to Touch Panel 

Control staff who can then manually remove the assigned device from the Token.

This process can take from 1-5 days for approval depending on when the request is received. 

However, requests are usually processed the same day they are received.

NOTE: If you need to register a device prior to having the Deauthorization request processed, then 

temporarily register the device using a 21-Day Trial Token. 21-Day Trial Tokens can be generated 

via the TRY links available on our Products pages. Then, once the deauthorization request has been 

processed, you can use the Token registration using TPCloud PIN method for re-registration of the 

device, which will overwrite the 21-Day Trial Token. Provided someone is able to enter the PIN on 

the device, the process can all be done remotely using TPCloud ,without the need to attend site.

Deauthorization using TPTransfer

TPTransfer provides the ability to immediately deauthorize a device, similar to the 'Deauthorize and 

re-assign by PIN' option available within TPCloud.

You will need to be able to access the device to apply the deauthorization.

Locate and select the device in TPTransfer, and then select 'Tools -> Deauthorize'.

Follow the dialog to complete deauthorization for the device and Token.
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How to access TPControl Device Settings

To access application Settings, begin by pressing the device HOME button.

Then, locate the Settings application icon, and select it.

Then, navigate to locate and select TPControl.

The 'TPControl for   Apple   - Device Settings' document can be obtained from the Downloads 
section of our website, and is also available within TPTransfer from the ‘Documentation’ drop-down 
option.

Please refer to this document for configuration options and device specific settings for TPControl.
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Note-worthy items:
● To configure connection parameters and Settings, refer to How to access TPControl Device 

Settings.

● TPTransfer will only connect to your device if TPControl is running.

● TPControl does not require a connection to an AMX NetLinx Master to communicate with 
TPTransfer.

● Uploading a TP4 file via TPTransfer while it is also open in TPDesign4 is supported, provided 
you are running TPTransfer with “Administrator” privileges.

● When Token registration is completed for a device, the registration information can at any time
be reapplied to the TPControl device using the 'Verify Device' option, available within Settings 
for TPControl on the device.
This may be required if TPControl has been running a trial-based license which has been reset 
by Touch Panel Control to extend the trial period.

● Any Settings options can be directly implemented within the TP4 user interface using API 
commands applied to 0-loopback port: command output as detailed in the
'TPControl - API Commands supported in addition to AMX commands' document, 
available for download from the Downloads section of our website.

This document is also available within TPTransfer from the 'Documentation' drop-down 
option.
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Known Issues

TPControl

● Certain Fonts may not appear correctly, particularly when non-standard indexing methods are 

embedded in the font file.

● We have endeavoured to support in TPControl the most commonly used AMX G3 and G4 

commands used for control and manipulation of AMX touch panels. However, not all functions, 

nor all parameters for these commands may be supported.

Please notify us through the HelpDesk if we have overlooked one of your favourites.

TPDesign4/TPTransfer

● If you re-install AMX TPDesign4 or apply an update, you may lose the TPC template options 

found in the "TPDesign4 -> File -> New> Panel type" menu.

To resolve this, run the TPTransfer XML patcher found in "TPTransfer -> Tools -> Settings -> 

Language and updates -> Patch TPDesign4" and then restart TPDesign4 to apply the changes.
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Problem Reporting

We aim to make your integration experience of TPControl within your AMX environment, as seamless 
as possible.

If you encounter any difficulties using the product or any of its features, please let us know and we 
will be happy to assist.

The helpdesk on our website at support  .  touchpanelcontrol  .  com operates from:

• Monday to Friday; 09:00 to 17:00 (GMT)
• Monday to Friday; 07:00 to 15:00 (AEST)

We appreciate your support,

Touch Panel Control Team.

AMX, NetLinx, TPDesign4 are trademarks of AMX, LLC registered in the US and other countries.
Android is a trademark of Google Corporation registered in the US and other countries.
Apple, iPod Touch, iPhone, iTunes and iPad are trademarks of Apple Inc. registered in the US and other countries. 
Microsoft Windows XP, Windows Vista, Windows 7 and Windows 8 are trademarks of Microsoft Corporation registered in the US 
and other countries.

All other trademarks and copyrights are the property of their respective owners.
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