NI Series (NI-700 and NI-900) 64 MB Duet v.4 Master Firmware v4.1.419

Last Updated: Sep 01, 2018

NI-700
NI-900

Programming Information

When upgrading to 4.x.x firmware from pre-4.x.x firmware for the first time, the upgrade process and subsequent reboot can take considerably longer than usual. The NI-X00 upgrade can take more than 15 min.

Firmware should be loaded in the following order:

There is no change to the NI Device firmware (device 5001), but if upgrading this firmware:

  1. Load the NI device firmware to the integrated device (normally 5001)
    For NI-700: SW2105_NI_700_Device_v1_30_8.kit
    For NI-900: SW2105_NI_900_Device_v1_30_8.kit
    The master must be rebooted following the installation of the integrated device firmware.
  2. Load SW2105-90_Master_v4_1_369.KIT (or higher) to device 0 via NetLinx Studio and reboot the master.

Changes in this release

  • Corrected problem with limited / no network communication following a power outage (xTrack RFI 24014).
  • Corrected problem with socket communication timeout (xTrack RFI 24607)
  • Corrected AMX Processors Vulnerable to SSLv3 POODLE by only supporting TLSv1.0 on HTTPS port (xTrack 25173)
  • Corrected problem with no scroll bars on Touch Panel remote access via internet browser (xTrack 24842)
  • Corrected LDAP checking to be case insensitive to match behavior of LDAP and NX masters
  • Added support for IPv6 when displaying an NX master's IP address through DATA.SOURCEIP in a M2M connection
  • Removed debugging account to prevent security vulnerability
  • Fixed SSL certificate generation/request creation to accept non-default values

 

Known Issues 

  • The DHCP lease information displayed via Telnet/Terminal "get ip" does not reflect the actual time the lease was acquired nor when it will be renewed/released.
  • If a Duet module, while loading during boot time, produces a Telnet error message: "java.lang.NoClassDefFoundError: org/xmlpull/v1/XmlPullParserFactory" you should update the Duet Module to the latest version.
  • Must use iWeather v1.1.6 or higher to operate correctly on 4.x.x firmware.
  • IE security does not allow G4WebControl to install by default and IE8 64-bit not supported.